Virgin Money failure since security updates

Hi Team

It appears I can no longer connect to my savings account with Virgin Money. Virgin Money updated their security sequence the other day and now requires OTP authentication to log in. When I try connect my account on Emma it times out. Is this an issue you are aware of?

Hey Grant,

can you reach out to live chat? We can double check from there.

I have the same issue - when Emma tries to sync to my Virgin Money account now, i just get text from Virgin money with a passcode required to login


this makes sense. They have enabled strong customer authentication.

We are working to migrate these connections to Open Banking.


I see that you have now migrated the flow which is good, however it’s worth mentioning that it doesn’t seem to work. At the stage where virgin money has shown you the account and data you’re sharing it then brings up a loading spinner saying you’ll be redirected to Emma and be logged out. However at that point no further action happens.

We’ve encountered similar during an open banking integration, where instead of relying on the customer to be redirected to us we had to start polling for changes in the background, but that will depend on which stage you expect to be able to exchange a valid token I guess.

As a minor aside on occasion I’ve noticed the initial login screen doesn’t show and instead an XML document displaying a 403 status code is shown


I’ve got the same issue. After providing my login details, confirming with the sms code and pick my credit card account, the process gets stuck on “redirecting to Emma”…

At this stage, you are in your web browser right?

I have found that simply refreshing the page a few times usually works. On iOS, I then get a pop up where I can select “Open App”, and Emma then opens (sometimes on a completely white screen and sometimes successfully syncing). If frozen or on the white screen, force close Emma and open it again.

The account should then be syncing.

Ok, so my procedure gets stuck on the “Transferring you back to Emma Technologies” screen. If I refresh, I get an error.
Both screenshots attached.

1 Like

Oh, thanks for the screenshots.

Based on the URL being the Virgin Money site, it seems like a bug at their end. We will have to wait for them to fix it. It worked OK for me the other day but perhaps they are doing weekend maintenance or something?

I would try again in a few days.

I tried on Friday too, no chance… I’ll continuously retry in the coming days. But surely it’s worth flagging this to @edoardomoreni


Retried this morning, the issue is still there.

Hey Team :raised_hand_with_fingers_splayed:

Thanks for raising this! I’ve raised this issue with the team this morning and they’re taking a look into it. Once it’s resolved, I’ll let you know here :wink:


Just for the record, to help you diagnose, it seems to be an issue only affecting new connections.

I set up the Virgin Money connection as soon as it became available, earlier last week, and it has continued syncing even while other users have been having issues with trying to authorise new connections.

1 Like

Thanks! Just to add to the investigation, I noticed in this screenshot that Emma is requesting access until 1 January 1970 (bottom of the page). Could this be the origin of the loop?

1 Like

On which side is this bug?

Just for a bit more information, when trying to link to a savings account I manage to enter all my credentials successfully and then get presented with the following:

These stupid banks cannot do anything properly. I wonder how their product and project managers don’t loose jobs.

A lot of these open banking products are fairly difficult to test outside of a live environment and due to so many banks implementing things slightly differently it’s not really surprising they run into a few glitches. Don’t think it’s necessarily product owners or project managers to blame

Haven’t they released it at the last day? :joy:

For starters, they don’t have “jobs”, they’re “consultants”, probably sub sub-contracted via a management company or two…