Error linking Virgin Money Current & Savings account

Hi everyone,

I have recently got the Virgin Money Current and Savings account. Both my app and Web are up and running now, also signed up for the separate online services that the API page prompt for. But I’m still getting an error page that says no payment account found. Has anyone experienced the same problem?

Hi @estera, this means the bank doesn’t suppor the connection. :slight_smile:

Their APIs only support payments accounts such as Current/Credit Cards or any other account that can be used to make payments.

Thanks for coming back @edoardomoreni That’s strange because I do have a current account there?

It might be better to try and link through Clydesdale Bank depending on Sort Code.

1 Like

@TheMightySwordfish is right.

These accounts will work with Emma, but you must connect them via either the Clydesdale (if your sort code starts with 82) or Yorkshire (if your sort code starts with 05) connections, rather than the Virgin Money option.

This is because of the merger between Clydesdale/Yorkshire and Virgin Money not being complete, so there are currently still two separate sets of systems.

The Virgin Money connection is for “old Virgin Money” savings accounts (pre-merger) and credit cards.

@edoardomoreni it’s important to be aware of this distinction, as all the accounts are supported in Emma!

I hope you get connected OK @estera

1 Like

@Seb @TheMightySwordfish Thank you both That sounds really possible, I’ll try again!

1 Like

Let us know how you get on! :slight_smile:

@edoardomoreni @Seb @TheMightySwordfish

I tried again using Clydesdale Bank. And this time is looking slightly more right than last time but still unable to connect. Think Seb is right about the integration!!

So I had the option to pick either or both accounts. I tried selecting current only, then current and Savings, then savings only but all attempts failed.

Then I was shown this screen.

Then it directed me to a blank page, the URL is as below

But the connection wasn’t made :frowning_face:

1 Like

Might just need to do it again. It can be a little temperamental now and again.

1 Like

That’s the right process, but at the end you should get a pop-up where you click “Open Emma”.

It could be that the webpage isn’t working because of an error at Clydesdale’s end. As @TheMightySwordfish says, it can be a bit tempramental.

You could also try downloading the Clydesdale app, as it may work through that - just login with the same details you usually use for Virgin Money.

Can you try again? We had some issues around 12.40. :slight_smile:

1 Like

Thank you all for the suggestions.

Tried again today via Clydesdale Bank. This time I got this error message

Can you send that screenshot to live chat?