11 - First Direct - Incorrect Format Error - SOLVED

Hi All :v:

Some users that are trying to connect First Direct accounts are getting the following error

We know this is an issue and we’ve reported it to the First Direct Open Banking team.

If you are encountering this issue, reach out to us via chat and we’ll add you to the ticket we’ve raised.

We’ll continue to update here on the action and responses we get back from First Direct :slight_smile:

Update 2nd April

No response from First Direct - followed up

Update 3rd April

No response from First Direct after follow-up yesterday. Will check back this afternoon

Update 6th April

No update from First Direct over the weekend. Followed up with them this morning

Update 7th April

Response back from First Direct. They require additional information in order to debug what’s going wrong.

We’re collating this new information and sending it off to them ASAP

Update from earlier today.

We provided First Direct with the additional details. We suspect that the issue lies with a new app update that First Direct have released. We asked First Direct to investigate with priority as it appears to be impacting all users that have updated to the new version of the First Direct app

Update 9th April

We’ve provided the additional details to First Direct, still waiting for them to get back to us

Update 14th April

Followed up with First Direct again asking them to get back to us

Update 16th April

This is the response we had from First Direct yesterday

We have investigated the issue on First Direct Version 4.0.2 (Appstore Version) on iOS 13.3.1 and on iOS 12.1.2 using Emma App - 2.6.3

We haven’t been able to reproduce the issue using multiple First Direct builds, the issue looks to be fixed in the Emma app release.

Given there have been several bug fixes it is possible the issue has been addressed in one of these versions.

Users have continued to report that they’re still having issues even with the new version of the First Direct app. We reported this to them yesterday and we’re still waiting on a response

Update 17th April

We chased them again today but they still haven’t responded :cry:

Update 20th April

No response over the weekend. Followed up with them again

Update 21st April

No response from First Direct after follow-up. Sent them another message asking them to get back to us

1 Like

Update 22nd April

Still no response from First Direct. We’ve reached out to their head of Open Banking to see if we can hurry along a response and we’ve sent another follow-up message to their team

1 Like

We’ve had word from some users that First Direct has recently released an update to their app and this resolves the issue.

The latest version of the First Direct app is 4.2.0. I’ve included a screenshot of the update below

We’ll keep monitoring the situation until we’re confident this does resolve the issue. In the meantime, try updating the app and connecting your accounts again :slight_smile: